# -*- mode: python; -*- #============================================================================ # Python defaults setup for 'xm create'. # Edit this file to reflect the configuration of your system. #============================================================================ #---------------------------------------------------------------------------- # Kernel image file. This kernel will be loaded in the new domain. kernel = "/home/takashi/work/kernel/build.XENU/netbsd" #kernel = "/home/takashi/xen/netbsd-XENU.gz" #kernel = "/home/takashi/work/kernel/build.kaeru.xen/netbsd" # Memory allocation (in megabytes) for the new domain. memory = 40 #memory = 70 #memory = 64 #memory = 32 #memory = 109 # A handy name for your new domain. This will appear in 'xm list', # and you can use this as parameters for xm in place of the domain number. name = "nbsd" # Which CPU to start domain on (only relevant for SMP hardware) #cpu = -1 # leave to Xen to pick #---------------------------------------------------------------------------- # Define network interfaces for the new domain. # Number of network interfaces. Default is 1. #nics=1 # Optionally define mac and/or bridge for the network interfaces. # Random MACs are assigned if not given. # The MAC address specified is the one used for the interface in the new # domain. The interface in domain0 will use this address xor'd with # 00:00:00:01:00:00 (i.e. aa:00:00:51:02:f0 in our example) # bridge is a required parameter, which will be passed to the vif script # called by xend when a new domain is created to configure the new # xvif interface in domain0. We can pass any information here. # In our example, the xvif won't be added to a bridge, but configured with a # private address. Pass the ifconfig line which will be used by the script # here instead. vif = [ 'mac=aa:00:00:50:02:f0, bridge=172.22.1.1 netmask 0xffffff00' ] #---------------------------------------------------------------------------- # Define the disk devices you want the domain to have access to, and # what you want them accessible as. # Each disk entry is of the form phy:DEV,VDEV,MODE # where DEV is the device, VDEV is the device name the domain will see, # and MODE is r for read-only, w for read-write. # VDEV doesn't really matter for NetBSD guest OS, but does for linux. # Worse, the device has to exists in /dev/ of domain0, because xm will # try to stat() it. This means that in order to load a linux guest OS # from a NetBSD domain0, you'll have to create /dev/hda1, /dev/hda2, ... # on domain0, with the major/minor from linux :( disk = [ 'phy:/dev/wd0i,0x03,w' ] #disk = [ 'phy:/dev/wd0g,wd0d,w', 'phy:/dev/wd0i,xbd1d,w' ] #disk = [ 'phy:/dev/wd0i,xbd0d,w', 'phy:/dev/vnd0d,xbd1d,w' ] #disk = [ 'phy:/dev/vnd0d,xbd1d,w', 'phy:/dev/wd0i,xbd0d,w' ] #disk = [ 'phy:/dev/wd0j,wd0d,w', 'phy:/dev/wd0i,wd1d,w' ] #---------------------------------------------------------------------------- # Set the kernel command line for the new domain. # Set root device. This one does matter for NetBSD #root = "/dev/wd0d" # extra parameters passed to the kernel #extra = "" #---------------------------------------------------------------------------- # Set according to whether you want the domain restarted when it exits. # The default is False. #autorestart = True